View Issue Details

IDProjectCategoryView StatusLast Update
877HdsFormsUser InterfacePublicApr 6th 2023 11:16 AM
ReporterTravis Herzog Assigned ToTravis Herzog  
Priority HighSeverityEnhancementReproducibilityN/A
Status ResolvedResolutionFixed 
ProjectionEnhancementETAUnder 1 Day 
PlatformWin32NTOSWindowsOS Version10
Product Version1.22.11.1 
Target Version1.23.0Fixed in Version1.22.11.2 
Summary877 : Add confirmation dialog when applying an options template
DescriptionDouble clicking a template currently causes the template to overwrite all of the users' current values, without warning. A confirmation dialog, which can be disabled on the template window, would help to prevent an accidental overwriting of values.

There is a message box when exiting, asking the user if they would like to save the changed values, but it is easy to instinctively click 'Yes'.
TagsEnhancement, Templates, User Input, User Interface
Installation TypeWorkstation

Activities

Travis Herzog

Travis Herzog

Mar 31st 2023 12:01 PM

Administrator   ~184

Fix committed with message 'Squashed commit of the following:

commit b6faa30a7297608fc2bf67421bd43dda0a814752
Author: Travis Herzog <travisherzog@hds-log.com>
Date: Wed Mar 29 10:56:01 2023 -0500

    Resolves 877 Add confirmation dialog when applying a template

    * Added message box before applying template, and a check box for disabling the message

commit 75d2eb255652ab0a6ccc341480e7f98871a15384
Author: Travis Herzog <travisherzog@hds-log.com>
Date: Wed Mar 29 08:20:00 2023 -0500

    Moved data set warning text about deletion to form string resources

commit 74d6183bc82c99d79cf5e7e79edf79a9d04a2cf9
Author: Travis Herzog <travisherzog@hds-log.com>
Date: Wed Mar 29 08:03:38 2023 -0500

    Resolves 878 Combine all duplicate forms from separate applications

    * Added moved forms EditZoneAddOrDelete, GetTitleForm, LargeMessageBox, OptionSets and QuickHelp
    * Moved public variable HasRemoveVersions to constructor argument in CurveSaveNameModes form
    * Updated form SelectCurvesOrUnits UI
    * Changed method LoadBackDoor() to constructor for form CurveSaveNameModesForm

commit d9e23c00d38d1852bda3b924c54fe4769b6bf39c
Author: Travis Herzog <travisherzog@hds-log.com>
Date: Mon Mar 27 16:44:03 2023 -0500

    Fixed text not selecting when clicking on a text box

    * Added helper event handlers Utils.Control_Click_SelectAll(), Utils.ToolStripItem_Click_SelectAll() which select all text in the sending control
    * Replaced text box event handlers with added helper Click event handler Utils.Control_Click_SelectAll()
' to master branch and 7a294b4b7e038fa013abccdc7692c2cc1bd44f0d revision in repository HdsForms with changeset ID 27681 at 2023-03-31T01:55:55+00:00.
Travis Herzog

Travis Herzog

Mar 31st 2023 6:06 PM

Administrator   ~190

Since the options template form was moved from Petro Calc to HdsForms, I've moved the issue and updated the summary accordingly.
Travis Herzog

Travis Herzog

Apr 3rd 2023 8:33 AM

Administrator   ~225

HDSlog 1.22.11.2 released
Travis Herzog

Travis Herzog

Apr 3rd 2023 9:31 AM

Administrator   ~229

Fix committed with message 'Merged 1.22.11.2 changes

commit 2ec36044b8cea75f502c7b4679d2ad5a056ac535
Author: Travis Herzog <travisherzog@hds-log.com>
Date: Mon Apr 3 08:57:12 2023 -0500

    Fixes 889 Object reference not set to an instance of an object. @ Void LoadQuickHelp() @ HdsForms.QuickHelpForm

    * Load Title Resource using TitleEnum instead of index

commit b6faa30a7297608fc2bf67421bd43dda0a814752
Author: Travis Herzog <travisherzog@hds-log.com>
Date: Wed Mar 29 10:56:01 2023 -0500

    Resolves 877 Add confirmation dialog when applying a template

    * Added message box before applying template, and a check box for disabling the message

commit 75d2eb255652ab0a6ccc341480e7f98871a15384
Author: Travis Herzog <travisherzog@hds-log.com>
Date: Wed Mar 29 08:20:00 2023 -0500

    Moved data set warning text about deletion to form string resources

commit 74d6183bc82c99d79cf5e7e79edf79a9d04a2cf9
Author: Travis Herzog <travisherzog@hds-log.com>
Date: Wed Mar 29 08:03:38 2023 -0500

    Resolves 878 Combine all duplicate forms from separate applications

    * Added moved forms EditZoneAddOrDelete, GetTitleForm, LargeMessageBox, OptionSets and QuickHelp
    * Moved public variable HasRemoveVersions to constructor argument in CurveSaveNameModes form
    * Updated form SelectCurvesOrUnits UI
    * Changed method LoadBackDoor() to constructor for form CurveSaveNameModesForm

commit d9e23c00d38d1852bda3b924c54fe4769b6bf39c
Author: Travis Herzog <travisherzog@hds-log.com>
Date: Mon Mar 27 16:44:03 2023 -0500

    Fixed text not selecting when clicking on a text box

    * Added helper event handlers Utils.Control_Click_SelectAll(), Utils.ToolStripItem_Click_SelectAll() which select all text in the sending control
    * Replaced text box event handlers with added helper Click event handler Utils.Control_Click_SelectAll()
' to master branch and 06f5a91884be3f9b2cfced67ca1d8eec5cbd070b revision in repository HdsForms with changeset ID 27851 at 2023-04-03T14:04:43+00:00.